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GIMP Brushes
Sets of GIMP Brushes are available on line (in GIMP brush format, gbr, gih, or vbr), but they cannot be 
grouped into a single brush icon like Photoshop brushes. They are saved as individual brushes. GIMP 
is able to open Photoshop (PS) brush sets. A single abr (format) PS brush set (icon) can include one to 
hundreds of brushes—so they are easier to handle and manage. Not all PS brushes will work in GIMP. 
Brushes made in CS1-5 are problematic, but brushes made in PS 10 won’t work in PS 7. (I usually make 
brushes in PS 5 or 7, so that they will work for most people in PS or GIMP.)

Most brushes should be thought of more as stamps than brushes: it is the dab or tip that is of most use. 
Unlike a shape, which is usually in one solid color, brushes can contain translucence/transparency, 
color, and, in special cases, can be animated. They can also be resized. 

Understanding how to use, store and manage brushes, as well as how to make them, opens a powerful 
tool to GIMP users. 

The various GIMP Brush types handle color, gradients, and transparency differently. 

Create Use
Mode Format Brush Tip

On White*
Foreground 

Color
Gradient 

Animation Brush RGB gih paints out no yes
Basic Brush Grayscale gbr transparent yes yes
Clipboard Brush† —— —— paints out no shape only‡

Color Brush RGB gbr paints out no shape only‡

Parametric Brush Grayscale vbr —— yes yes
*  Depending on the brush type, white can be transparent or it can be opaque (paints out what is underneath).  
† The Clipboard brush is volatile: unless it is saved, it will disappear as soon as something else is put on the clipboard. In 

most respects, it acts like a color brush. It can be saved 
‡  The shape of the brush can take on the color(s) of the gradient (with Use color from gradient ticked). Transparency/detail 

is lost. 

Every brush in this tutorial is shown as a paintbrush, adding color to something. These same brushes 
can be used as Eraser, Dodge, Burn, or Clone Tools. They can be used at 1-100% opacity and with dif-
ferent layer modes. 
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Part 1: Using, Storing, Managing Brushes
When I first started in Photoshop 4, I couldn’t understand the fuss over brushes. Within a few years, 
I had hundreds of brushes. Although Photoshop manages brushes a better than GIMP, storing them 
can be come a problem. This section deals with setting up a good system for keeping your brushes. 
It is well worth the trouble to start out right. 

Paintbrush Tool 

There are a number of tools in the Paint Tools cat-
egory. Most of them that can use different brush-
es with varying success: Paintbrush, Eraser, Air-
brush, Clone, Healing, Dodge/Burn, etc. For this 
tutorial the focus is on the Paintbrush.

To select the Paintbrush, click on the     icon in 
the Tool Box; or Tools>Paint Tools>Paintbrush. 
The lower part of the Tool Box has the Paintbursh 
options—see illustration A. By default, most of 
the options are contracted, but by either clicking 
on them (Brush Dynamics) or ticking the boxes, 
they expand. 

Modes—GIMP has twenty-one modes. The default 
mode is Normal: the pixel you paint cover any pix-
els or transparency below. In terms of Modes, it is 
often convenient to think of the painted layer as a 
mask: in Normal mode, the painted layers masks 
out the pixels immediately below them. The way 
a blending mode effects what is visible can be de-
scribed arithmetically, (See Modes:  http://docs.
gimp.org/2.6/en/gimp-help-index.html); but trying 
them in a given situation is generally a better way 
to know what each mode can do. These modes are 
often more effective when applied to the layer that 
was painted on, as layer modes, than to individual 
brush strokes. Changing a mode only changes the 
next brush strokes, not the previous strokes. A sin-
gle layer can have brush strokes that are themselves 
in different modes. Opacity—this slider or number 
box increases or decreases the opacity or translu-
cence of a brush stroke. As with modes, changing 
the opacity changes the next brush strokes, not the

A
pervious ones. A single layer can have brush strokes 
are of varying opacity. Brush—the little square is 
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the brush tip or dab. Click on it and a Brush Palette 
or dialog drops down. You and change brushes, 
but unlike the Brush Dock (Windows>Dockable 
Dialogs>Brushes) you cannot access the Brush 
editor, etc. Scale—this slider, or number box, con-
trols the size of the brush, from 0.01 to 10.0. Most 
people use the “[” and “]” keys (keyboard short-
cuts) to increase or decrease the brush size. Brush 
Dynamics—are brush effects—opacity, hardness, 
size, and color— that can be controlled by pres-
sure (tablet only), speed (tablet and mouse), and 
random (tablet and mouse). Fade Out—causes 
each brush stroke to fade from full strength to 
transparent. The adjustment let you set the length, 
in the units of your choice, of each stroke until it 
fades out Apply Jitter—jitter causes the brush tip 
to giggle to one side or the other of the paint line.      
Incremental—this is a blending mode, where the 
effect of overlapping brush strokes are additive 
where they intersect, but only to the maximum 
opacity. Use color from gradient—the paint color 
is determined by the active gradient. To change 
the effect, change the gradient.      
 

Examples of some of the brush options: A. soft brush; 
B. hard brush; C. dissolve mode at 50% opacity; D. 
50% opacity; E. fade; F. jitter; G. gradient; H. spacing 
(on the Brush Dock); I. jitter and spacing.

These effects can be combined. The possibilities 
are virtually unlimited.

Another type of Brush
Why are some people crazy about brushes? For 
basic work, cloning, painting, erasing, filling or 
stroking a selection and a simple soft and hard 
round brush are all you need. These are the stan-

dard brushes in GIMP:

Brushes can be moved, or stamped (a mouse click).  
The single cross, pepper, square, and circles were 
clicked once. Everything else was brushed on.  

These are fourteen brushes from three different 
Photoshop brush sets, Hieroglyphics, Bamboo 
Brushes, and Swirl Elements.1 The advantage of 
working with brushes is that they can:

be resized without loss of detail•	
hold full grayscale information•	
hold full color information (GIMP’s animated •	

1 From www.creativedrawer.com, created by Lissalei and 
Walton Mendelson
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peppers brush is color) 
be animated•	

To work with them effectively, you would work 
with brushes on different layers. The bamboo 
is made up of 9 brushes. I quickly grabbed each 
brush, resized it and stamped it on its own layer, 
using the default foreground color. I had to rotate 
and reposition several layers. This took maybe five  
minutes. Effects could be applied to these brush 
dabs—drop shadow, bevel and emboss, outer glow, 
inner glow . . .  

Brush Dock

Clicking Windows>Dockable Dialogs>Brushes 
brings up the Brushes dock:  

Each dab in the panel is a brush, and all of the 
currently available brushes are indicated. Click 
on the brush tip, and that becomes the currently, 

active, brush. Brush in the Paintbrush Tool op-
tions, brings up a similar dock, however, the icons 
are different and it is where you can adjust the 
spacing:  

Spacing—each brush stroke is made up of one 
or the dabs of the brush tip. The Brush Dock 
shows single dabs. Example H on the previous 
pages shows spacing set to 60 for that particular 
brush. Edit Brush,     —opens the Brush Editor. 
Not all brushes can be edited: only parametric 
brushes and not GIMP’s default brushes. New 
Brush,    —opens the Brush Editor. Dupli-
cate brush,    —duplicates the current. Delete 
brush,    —deletes the current brush. Refresh  
brushes,    —refreshes the brushes.  

The Brush Editor looks like this whether it is for 
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editable, new, or read only brushes. 

On the left, the square was selected as the base 
shape for a new parametric brush. On the right, it 
has been altered using spokes, hardness, aspect ratio, 
and angle. 

These brushes are stored in the Personal Brushes 
folder. 

Storing & Managing Brushes

If you start collecting brushes, you need a filing 
system that lets you locate the brushes you want, 
load them, and when you are through, go back to 
a small manageable default set. My preference is 
for Method 3 below.

1) The GIMP manual suggests putting all brushes 
in your personal brush folder, then when you re-
fresh your Brush dock, they will all be there. 

2) Another method for brush users, is to keep the 
brushes in separate folders. These can be kept by 
brush type, and the path to each folder entered 
in your preferences. 

3) Whichever folder you enter in preferences, you 
copy the brushes you want into that folder, and 
delete them when you are through. 

Method 1: Your Personal Brush File

Brushes you create in the Brush Editor are auto-
matically stored in your personal brushes folder.
For most people, this folder is located:
c:/Documents and Settings/my name/.gimp2.6/brushes

If you are unsure of where your Personal Brush File 
is, go to your Preferences>Folder>Brush Folder:

Click on Edit>Preferences. On the Edit drop- down 
menu click on Preferences, located about ⅔ of the 
way down. 

B: This opens the Preferences dialog. At the bottom 
of the left-hand window, click on the + to open the 
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list of personal subfolders. GIMP lets you store a 
wide variety of customized setting and items, like 
brushes. 

A

In the folders list, click on the Brushes folder:

This shows the path to your personal brush folder. 
Write it down. When you create brushes in the 
Brush Editor, they are stored in this folder—GIMP 

knows this so it’s not a problem, but when you 
download a brush, you have to put it where Gimp 
can find it. When you download a brush you will 
be asked if you want to open it or save it. Tick Save, 
and you will be asked where you want to save it.   

Method 2: Creating Your Own Brushes Folders
For brushes you download you might want to cre-
ate special folders with names that will distinguish 
one type of brushes from another (e.g. flowers from 
grunge). Create these folders where and how you 
normally create folders.

In the Brush Folder Preferences, you can click on 
the new icon (    ) a red ball will appear next to a 
window: type in a new path (e.g. d:\gimp brushes\
flowers). When you click enter, it will appear in the 
large window below. Tick the box if you want to 
load those brushes. You will have to close GIMP 
and reopen it for this to take effect.

NOTE: Some brushes and some folders can 
cause problems in opening GIMP. When you 
close GIMP, to be safe: 

because you copied the brushes into the •	
folder, delete them, or 
rename the folder, or •	
move the folder. •	  

Method 3: Copy, Paste, and Delete
Now that GIMP knows to look in a folder for 
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brushes, you can copy and paste brushes into that 
folder, and click Refresh at the bottom of the Brush 
Dock (Windows>Dockable Dialogs>Brushes),     , 
and the brushes will load. If you delete them from 
the Personal Bush Folder when you are done, you 
should avoid problems. Because you are copying 
them not moving them, it is safe to delete them 
from the Preferences Brush Folder because you 
still have them in your folders.  

Not only do lots of people make GIMP brushes; 
but many Photoshop brushes work in GIMP. If 
the brushes say for PS 7 and up, they probably 

work; if they say CS2 and up, they probably don’t. 
When you download brushes, or buy them, read 
the terms of use, ToU, or end user licensing agree-
ment, EULA.   

If a brush does not open in GIMP, do not leave it 
in the folder with the other brushes—move it or 
throw it out.  

When you open GIMP all of the brushes in the 
brushes folders paths will open in the Brushes 
Dock.  If you add one while working, refresh will 
add it to the Brushes dock. A little planning can 

Did you know?

To draw a straight line: 
1. Left click where you want the line to start
2. Hold the Shift key, and you will see a line form between the 

start of the line and where you want to end it.
3. Left click to generate the line. 

To draw a horizontal or vertical line:
1. Left click where you want the line to start.
2. Hold the Shift key, and you will see a line form between the 

start of the line and where you might want to end it.
3. Hold the Ctrl key and the line will snap to the nearest 15° 

increment from vertical—in this case that is horizontal.
4. Left click to generate the line. 

To enlarge a brush: 
Use the ] and [ keys to enlarge a brush while you are using it.

Select Color while painting: 
To sample a color while you are painting and turn it into the foreground color, hold the Ctrl key down 

and the brush temporarily become an eyedropper. 
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If you are unsure how to use brushes, or all the 
options available to brushes from size and opac-
ity, to blending modes, see page xx. 

Clipboard Brush
When you use the Copy, Copy Visible, or Cut 
commands on an image or a selection, not only 
does that content go to the clipboard, but it be-
comes a Clipboard Brush. This is the first brush 
in the Brushes Dialog. It is however, volatile: it 
will disappear either when GIMP is closed or it 
will be replaced the next time anything is put on 
your clipboard   

You can save this brush by using Edit>Paste 
As>New Brush. This opens the New Brush dialog: 

Brush name—type in a descriptive brush name, 
“my brush” isn’t good. File name—this is the Per-
sonal Brush Folder in Preferences>Folders>Brushes. 
You cannot enter a path to another folder. Spac-
ing—Sets the space between dabs if the brush is 
dragged. This can be changed when the brush is 
selected.   

Ordinary Brushes
These can be black and white or color, and they 
can have transparency. When you make an im-
age, save it as a gbr, GIMP’s basic brush format.  

You do this by simply clicking on File>Save As. 

Saving an image as a brush through Save As, per-
mits you to name the file and designate what file 
it goes to, just as you would save any image.  Click 
on Select File Type and select GIMP Brush.  

If the image is multi-layered, you will get a mes-
sage, asking if GIMP should merge visible or flat-
ten your image before converting it to gbr.  

Next, you’ll get a screen that asks for a descrip-

Part 2: Making Brushes
It’s not just that the brush you want is personal use only, but that much of what you want you just 
can’t find. For the sake of argument, anything you can make or do in GIMP can become a brush. 
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tions: 

If you saved this brush in your Personal Brush 
Folder, then click the refresh icon on the Brush 
dock, and it will be available to use. If you saved 
it to a different folder, copy it and paste it into 
the Personal Brush Folder, click the refresh icon, 
and it will be available to use. 

Parametric Brushes: 
Brushes made in the Brush Editor are called para-
metric brushes. See the section on the Brush Edi-
tor, pages 4-5.

Animated (Image Pipe) Brushes
Of all the brush types, this may seem at first 
blush to be an impractical brush. When might 
you need animation?  

But suppose you want a field of starts streaking 
across the an image? 

I could just as easy have a solid field of starts.

Every brush stroke sprayed out stars. I made the 
file in about 10 minutes. I used Spacing, Jitter, and 
Use color from gradient, it has 8 layers. It could 
have a hundred. 

I made a basic start shape, bottom layer, then 
duplicated it eight times. I rotated and reduced 
the size of each of the duplicate layers.   

When the layers are complete. Save the brush as 
a GIMP brush (animated): 

The name of the brush is the file name. 

Clicking Save brings up the Brush Pipe dialogue. 
There is somewhat involved description of this 
in the GIMP Manual (http://www.docs.gimp.
org/2.6/en/gimp-using-animated-brushes.html). 
You can save the image as a xcf file, or opening it, 
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the gih file, and change the settings in the Brush 
Pipe dialog. 

Spacing—this sets the spacing between dabs. De-
scription—this is the description of the brush. In 
the Brush dock, you can change the view as list 
by clicking the Configure this tab: 

In the fly-out menu, click on View as list. Next to 
each brush dab is the description. (Because you  

are likely to have to try a few times to get your 
brush the way you want, it is important to be able 
to distinguish between versions.) Cell size—this 
is set by default  to once cell per layer at the size 
of that layer; although a bigger layer could be cut 
into two or more cells. Number of cells—by de-
fault this is the number of layers, but again, this 
could be changed. Display—this shows how the 
cells/layers have been arranged. Dimensions and  
Ranks—when you have more than 1 cell per 
Selection (next to Ranks)—random: selects im-
ages in random order; incremental: selects images 
in the order they are in the dimension; angular: 
selects images based on the angle of the brush; 
Speed, Pressure, x tilt, y tilt: are options available 
to tablet users. (Refer to the GIMP manual for 
more details.)

If you are interested in animated brushes, you 
should look into GAP (a GIMP plug-in to assist 
in creating image pipes), downloadable at: ftp://
ftp.gimp.org/pub/gimp/plug-ins/v2.6/gap/
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Part 3: Simple Brush Tutorials 
If you are new to brushes, it can help to follow a few projects to get a sense of how to make 
them, and how to take advantage of GIMP’s many features. 

Type: Watermark

A great brush to keep handy is a watermark:

If I were posting this image, I would use this wa-
termark (© 2010 Walton Mendelson). Yes, it is 
hard to read, but it is a good notice,1 and the image 
is basically intact. This tutorial will show you how 
to make a simple watermark brush. The brush 
dab could be larger, smaller, placed in the middle, 
or the top—anywhere, any size you want—and, 
as you’ll see at the end, different based on the 
blending mode.

In general, I make brushes (an most images) start-
ing with a bigger image size and maybe even a 
higher resolution than I will finally need because 
it is always better to work bigger and have more 
room, then crop and resize down the final image, 
than it is to struggle to make things fit inside too 
small an area or enlarge something that is too 
small. However, all of the following brushes are 
high resolution brushes (many brushes on line are 
lo res, an inch or two square at 72dpi). 

1  For copyright information http://www.copyright.gov. You are 
the author of your work and you have an automatic copyright 
in it at the moment it is created. You do not need either the 
notice or registration to have this copyright. But putting notice 
on your work, especially on the internet, is a very good idea. 
Also, you can register a collection of images: you don’t need 
to register your images singly. 

With the new image open, select the Type 
Tool,    . This brings up the Text Editor. Al-
though you can type directly in the Text Edi-
tor box, it is easier and safer to type in a word 
processor, then copying and pasting the text 
into the Text Editor. To get a © symbol, hold 
down the Alt key and type 0169; you cannot 
do this in the Text Editor; although you can 
copy and paste the © symbol into it. 

What you type appears in the Image Display. 
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You can change the text effects: size, typeface, 
leading, etc. in the Type Tool Options.  Select 
(highlight) the text in the Editor and change the 
options. 

The box around the type on the Image Display, is 
like a rectangular selection: you can resize the it 
by clicking and dragging an edge. 

I am going to add an extra step or two. I think 
they are aesthetically necessary, but that depends 
a lot on the type face you’ve chosen.  

Alpha to Selection is important to know, under-
stand and use. It lets you select a shape—letters, or 
an object—and do something to it: fill it with pix-
els on another layer, use it to copy part of another 
image to its own layer, filter it, apply effects to it. 
When you first start working in GIMP, you will 
probably ask yourself a hundred times, why would 
I ever need this? Alpha to Selection you’ll need. 

I’ve done several things: 
I’ve applied a gradient to the background or •	

bottom layer. I did this to see the effect of 
what I want to do, not on a solid white or 
black, but on something that had different 
hues. I’m going to throw this layer out, so 
what I fill it with is irrelevant. 
I used the selection of the letters in the text •	
layer (Alpha to Selection) to create white let-
ters in a layer above it. I made a new layer, and 
with the selection, marching ants marching, I 
filled the selection with White, Edit>Fill with 
BG Color (ctrl .)  
I duplicated that layer (the White letters layer) •	
so if what I was doing did not work, I could 
quickly start over. 
And I have started to select Gaussian Blur to •	
apply to that copy layer: Filter>Blur>Gaussian 
Blur.

Note: It would have been quicker to apply 
the Gaussian Blur directly to the type layer. 
But a prudent workflow is to work with copy 
layers.

Gaussian blur softens, feathers, the edges of the 
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letters. The Preview shows you the effect. 

Having applied the Gaussian Blur, I am now 
going to apply Emboss to the same layer.  
Filter>Distorts>Emboss.  

 

Here is the almost completed watermark brush.  
Yours may look different if you chose a different 
type or worked with it in a larger size.  

I turned off the gradient layer, so all that is on is 
the blurred and embossed layer. I have selected 
around it with the Rectangle Tool,    . Then I 
copied it: Edit>Copy, or to be safe Copy Visible. 

This brings up the New Brush dialog: 

Although the dab of this brush is unique, give 
it a Brush Name that is useful. The file name, 
“mybrush” is your Personal Brush Folder. When 
you click OK, the brush is saved and on the Brush 
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dock, Windows>Dockable Dialogs>Brushes. 

To use the watermark brush, make a new layer 
above the image you want to mark. Select the 
Paint Tool, and click on this brush. Resize it and, 
in this case with white as the foreground color, I 
stamped the brush with one click of the mouse. 
Then I used the blending modes on the new layer, 
to get the effect I wanted, which was overlay. Here 
are the effects on my image: 

 

Shape: Floral Swirl

These are quite popular and useful: they can be 
used on anything from scrapbook pages and sta-
tionary, to fine art work.  

The best swirls are made as vector art (Adobe 
Illustrator or Inkscape), but with GIMP’s Path 
Tool (aka Bezier Curves) you are working in that 
world. The biggest difference is that the final 
GIMP image, before saving as a brush, is a bitmap 
(raster ) image. 

To prepare your swirl: 
you can draw the swirls with a tablet and pen •	

in GIMP
you can work with French curves, drawing •	
on paper, scan your drawing, and prepare the 
graphic art to become a brush; 
you can work in Illustrator or Inkscape, save •	
the swirl as a esp file, then open it in GIMP;
you can work with Path Tool. •	

For this tutorial, I will use the Path Tool,     . 

To get a basic shape you can look at swirls—
Dover has many excellent books that are great 
reference—or you can scan something with swirls 
in it. Usually what you scan or draw will need to 
be cleaned up, so for this I just drew a quick and 
rough rough curve on my tablet.  
 

Now, with the pen tool, “draw” around the swirl. 
I work loosely at about 100% magnification, when 
the path is roughly where I want, I finesse the 
curve. 

A few words about the Path Tool (see GIMP 
Basics, pg for more information): Select the Path 
Tool, position the cursor where you want the first 
Anchor Point. You will work your way around 
the curve and close the path, connecting the last 
and the first anchor points by holding down the 
Ctrl key. You can, as in this tutorial, connect the 
path early on, and add Anchor Points to extend 
the path.  

Here is what it will look like when it is com-
plete:  
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The power of GIMP’s Path Tool is that: 
anchor points can be moved; •	
the curves between points can be adjusted;•	
points can be added or removed;•	
paths can be converted to selections and filled •	
with color;
paths are saved in GIMP’s xcf files.•	

 
Use the assist keys (e.g. hold the Shift key when 
you click to create a new anchor point) with the 
Path Tool cursor to close, add and delete. Click 
on an anchor, and pull the handles out. Use the 
handles to shape the path.    

The bottom layer in the file is white, all the layers 
above are transparent. Initially, I worked at 100% 
magnification and closed the path around the 
curl on the left: 

This first path can be much looser than this. Be-
cause the curve was wide, I chose to start at 100% 

magnification. to add additional point around the 
curve, I dragged the anchor points on the right, 
out, along the curve then added points as neces-
sary. You could just as easily quickly work your 
way around the entire swirl. Don’t forget to use 
the Ctrl key to assist in closing the path. 

The following show how the path gets finessed:

The fussier sections require working at 600%: 

Here, towards the end of the swirl, I’ve dragged 
the end point and added a new Anchor Point:
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Even working at a high magnification, it is hard 
to know if the path is done until you fill it: in the 
Paths Dock, click on Path to Selection: 

On a New Layer fill the selection with black to see 
the effect of the Path. To remove the marching 
ants, Select>None or Ctrl Shft A.

It’s much better than my sketch, but it’s not fin-
ished. I turned the layer off, eyeball off. I selected 
the Path Tool, turned on the layer with the path 
in the Layer Dock, and to bring the path back,

clicked on the Path eyeball (see the Path Dock 
above).  

To bring the Anchor Points back, click on the 
path. Click on the Anchor Points to drag out the 
handles. Continue moving around the swirl to 
smooth the curve.  

Here is the finished swirl (covert the path to a 
selection, on a new layer fill with black): 

To make this a brush, turn off the white back-
ground, with only this filled selection on, draw a 
rectangular selection around it, copied it, Edit> 
Copy or, to be safe, Copy Visible, then Edit>Paste 
as>New Brush. In the 

Name the brush with a good description. When 
you click ok, the brush is made and saved to your 
Personal Brush Folder. 

  
Scanned: Coffee Rings and Splatter 

Most people think that there’s a short cut to splat-
ter brushes (or coffee mug rings, etc.), well the 
secret is to make them on paper, then scan them 
(okay, some paint programs like Corel Paint have 
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water color and splatter effects.) Use coffee or wa-
tercolor paint for thing rings. Use watered down 
paint, watercolor or acrylics for splatter. The type 
of paper you use will react differently to the splat-
ters and coffee rings Splatter can be made a tooth 
brush or bristle brush; or use a straw and with a 
little bit of paint in the straw (⅛—¼ inch) blow 
into the other end. 

Here is a coffee ring made with real coffee.

Nice, but it’s too light. To change the density of 
the ring, open Levels: Colors>Levels. All color 
adjustments are destructive—that is, they change 
the pixels of the layer applied to.  To avoid prob-
lems, duplicate the Coffee Ring and apply Levels 
to a copy of the layer.      

The biggest change will be with the black point. 
Move the Black triangle slider to the right. i move 
the White point, White triangle, very slightly to 

the left. Click OK to accept the change. 

You could quite here and make a brush, but the 
hallmark of good brushes is that they are clean 
where they should be clean.  

Click on the white background. The marching 
ants from the Fuzzy Select Tool show the dirt. 
One way to get rid of large areas of dirt is to 
use Subtract from Current selection and Invert 
(Select>Invert): 

As above, select the white with a low thresh-1.	
old
Hold the Ctrl key down, then using a selection 2.	
tool (Rectangle, Ellipse, or Free Select Tool) 
go around the image to deselect, subtract,  
the dirt. 

With the Ctrl key down, I kept making selec-
tions until most of the dirt is not marked by 
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marching ants. I am not going to try to get it 
all, must most.  

3.     I want the coffee ring on a transparent layer, 
so add an alpha channel: Layer> Add Alpha 
Channel. 

4.     To get rid of everything except the coffee ring,
which is currently selected, invert the selec-
tion: Selection>Invert, or Ctrl I. 

5.    Click Delete or Edit>Clear.

You could have left the image on white and made 
a grayscale image, so the white background would 
not appear in the brush, the dirt would still be 
there. Instead of deleting the white, you could 
have filled it with white: but again, the dirt would 
still be there. 

The easiest way to see the dirt is with a “slip sheet”: 
a white or black layer underneath the working or 
layer:  

The white dandruff is light dirt; there may also 
be dark dirt, which shows up with a white “slip 
sheet.” Erase these with the Erase Tool,     . 

I like to save this sort of brush as a grayscale, 
Image>Mode>Grayscale. That way I can use it 
with a foreground color or gradient. 

If you use a mouse to click the brush, if you don’t 
move it, you can double or triple click a brush dab 
to darken an otherwise light or translucent dab. 

Splatter is a lot easier: what is dirt in something 
like the coffee ring, is desirable in splatter. The 
easiest way to make your own splatter or drips, 
is to make your own splatter or drips.  

Mix a little acrylic paint, say black, with a few 
drops of water to a consistency of cream. You can 
use a straw to dip into the paint, then either flick 
it or blow/spit into the other end onto any sort of 
paper you want.  Experimenting is fun, but messy. 
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NOTE: If you suck a little paint into the straw, 
don’t suck more than enough for a 1/2 inch. Put 
extra paper around your target, clean up with 
water when you are finished. I find that I can 
get as many six splatters on a piece of paper.  
Allow to dry before scanning. 

I am going to make a brush out of the upper right 
splatter; shown with guidelines. 

 

With the Free Select Tool, I selected around the 
splatter.  

This looks pretty good, but the white background 

isn’t as white as it should be, and it will therefore 
create an unpleasant cast if the brush were made 
from this. The easiest way to adjust this black and 
white image: Colors>Brightness-Contrast. 
 

These are the settings necessary: here is a com-
parison (before and after adjusting the contrast 
and brightness): 

With the mode set to Grayscale, Image>Mode> 
Grayscale; I copied the finished image (all bright 
white) Edit>Copy then Edit>Paste As>New Brush. 
Here is is on black, the white background is gone: 
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NOTE: when scanning you want as much infor-
mation as possible. Scan in color, even if you 
want grayscale. Adjust the contrast, brightness, 
sharpness, color balance, in GIMP on the scan, 
not in your scanner. I often scan at 600 dpi 
then reduce the dpi in GIMP, later.

Animation Brushes

Animation brushes probably seem somewhere be-
tween distant to unnecessary. Like lots of things 
in image manipulation programs, once you try 
something and understand it, you often find uses 
for it that never occurred to you before.  

Suppose you wanted a quick field of plants:

 

Used with a green gradient, it’s not too bad. If it 
were a struggle, it might not be worth it, but this 
was about ten minutes work. 

Above a white background, I drew a single leaf 
and stem.  I kept it translucent. Then I copied the 

leaf layer, and flipped it horizontally, with the Flip 
Tool,     . I kept duplicating the layers, changing 
the rotation with the Rotation Tool,     , and 
resizing with the Scale Tool,     . 

 

Although the image is RGB, the image is black 
and white, and the transparency and density is 
preserved using a gradient. 

The next step is to save the image as a Gimp ani-
mation brush, gih. This is fully documented in 
the previous section. 

If you did not save the image as a xcf file, you can 
still open the gih brush, and have access to all the 
layers, you can rework the image, and you can 
save it however you wish. 



 



Look for GYMP Supremacy by Walton Mendelson scheduled for release fall, 2010,
from One Off Press

www.oneoffpressbooks.com   


